HUD Service Disruption

Incident Report for Marfeel

Resolved

The issue has been fully resolved and all systems are operating normally. Thank you for your patience.
Posted Apr 27, 2026 - 14:59 CEST

Monitoring

The issue has been identified and a fix has been implemented. We are currently monitoring the situation to ensure stability.
Posted Apr 27, 2026 - 14:49 CEST

Investigating

We are currently experiencing issues with the HUD. Our team is actively investigating the problem and working to resolve it as quickly as possible. Thank you for your patience.
Posted Apr 27, 2026 - 14:29 CEST
This incident affected: Heads Up Display (HUD).